MG-Cars.net

Welcome to our resource for MG Car Information.

Recommendations

Parts

MG parts spares and accessories are available for MG T Series (TA, MG TB, MG TC, MG TD, MG TF), Magnette, MGA, Twin cam, MGB, MGBGT, MGC, MGC GT, MG Midget, Sprite and other MG models from British car spares company LBCarCo.

MG MGA - I finally drove it!! But ------

I finally drove it! But I still have an electrical problem. The ignition key turns but nothing happens, and yes there are 2 brown and 2 white wires connected. The previous owner ran a jumper between the 2 fuses and it will start and run but the ignition key does nothing. I ran a jumper from A1 on the control block and the upper right fuse and it started. Also the ignition key now works. I really donít want to drive it with a jumper. I will post some pics of the car after my wife shows me how to shrink them as the files are to large. Any thoughts on the electrical problem?

Thanks in advance
Dave
david kirkpatrick

See ignition circuit here: http://mgaguru.com/mgtech/electric/circ_i.htm

You have a disconnect somewhere between control box A1 and fuse box A3. There are only two wires and the ignition switch in between those two points. Grab a test light: http://mgaguru.com/mgtech/tools/ts129.htm
Ground the tail, and start poking wire connections. You should get light from both ends of the Brown/Blue wire, which is always hot. With switch on you should get light from both ends of the white wire, which is hot with switch on. Where you don't get light you have a disconnect. Could be a bad ignition switch.

If you don't have a test light, a volt meter works as well.
Barney Gaylord

Barney, thanks for your input. Using the test light the brown/blue wire is NOT hot at A1. "A" on the control box is hot. Thanks in advance.

Dave
david kirkpatrick

Is that the car that was on eBay several months ago...something strange about the paint? As I remember you got a good deal on it?
Gene Gillam

If A is hot and A1 is not, there is a disconnect inside the control box. See here: http://mgaguru.com/mgtech/electric/circ_c.htm
Barney Gaylord

Gene, yes this is the car that I paid $5000 but bought from an individual. I've put tires on it,new rear brakes and a master cylinder. The paint looks great from five feet and it appears to be a bad primer. Looks good so I will hold off painting it for a while. I posted a pic yesterday. Now if I can gust solve the wiring issues.

Barney, thanks for the quick response and I will look to see what is disconnected in the box.
david kirkpatrick

Barney, there is a broken brass(?) piece broken off in the rear of the control box. About an inch gap. I assume that I can solder it ??

Thanks

Dave
david kirkpatrick

Haven't seen it. How about a picture?
Barney Gaylord

This thread was discussed between 16/09/2013 and 17/09/2013

MG MGA index

This thread is from the archive. The Live MG MGA BBS is active now.