MG-Cars.net

Welcome to our resource for MG Car Information.

Recommendations

Parts

MG parts spares and accessories are available for MG T Series (TA, MG TB, MG TC, MG TD, MG TF), Magnette, MGA, Twin cam, MGB, MGBGT, MGC, MGC GT, MG Midget, Sprite and other MG models from British car spares company LBCarCo.

MG MGB GT V8 Factory Originals Technical - Flat batteries?

Right its time for the old V8 to increase my stress levels again, its new trick is to start up ok, engine spinning healthily on starter, drives along ok, but if I stop and turn engine off (or worse stall at a junction-when engine cold and in tempermental phase) I get the flat battery response, starter churns slowly, not fast enough to start engine, leave car for possibly a few minutes and re try, starter speed improves and car starts, at first i thought it was starter connections, cleaned them up and it made an improvement ,but problem returned, so cleaned up and replaced various battery terminals and earths (batteries are a year old), today I changed alternator, and thought I had it sorted, just driven into work and guess what, flat batteries again, fine before I drove the 7 miles to work anyone got any ideas? ps where is the engine earth strap, and also starter earth?
cheers

Nigel
Nigel Griffiths

The 'engine' ground strap is between the gearbox and the removable cross-member. There is no seperate starter ground. Seeing as how it cranks when cold you need to do some diagnostics, measuring the cold cranking voltage at the battery posts and solenoid terminals, and again when hot. Lower voltage indicates bad connections or battery, higher voltage indicates a problem in the starter or solenoid. The factory V8 also differs from other MGBs in that there is a stud under the right-hand toe-board where the brown wires to the alt and the rest of the cars electrics connect to the main battery cable. Hence it is possible to get a bad connection to the starter that does *not* affect the rest of the cars electrics i.e. no dimming lights during cranking.
Paul Hunt

Thanks Paul;
I have since replaced batteries with a new single 12 volt, and also replaced alternator, car drove fine for last 4 days before once again battery flat, I have checked all connections etc, the only one I stopped at was the toe board stud, its on a removable plate (2 nuts)and both cables going in/out have a rock hard plastic terminal covers, has anyone found a problem with these connectors? should I cut off insulation to check?

thanks for any help

Nigel
Nigel Griffiths

PS

I checked for leakage from battery with igniton off, no current flow found
voltmeter did register approx 2 volts, which immediately returned to zero...capacitor on alternator live?
Nigel Griffiths

Nigel
Which 12v Battery have you used as I would like to change my 6v ones.

Hope you get the problem sorted.
Mark Rawlins

Mark

I Fitted a Bosch Silver-46A/H battery as an aid to fault finding only, (turns engine over no problem, when charged! and only 36.)previous 6 volt batteries only a year old, so will refit those when fault located

cheers

Nigel
Nigel Griffiths

Take the battery ground strap off and connect a voltmeter in its place, you should see a few volts but less than 12v. The few volts is reverse leakage of the alternator diodes and is normal, if you see 12v you have a drain. Remove the alternator plug and if the volts drop to zero the alternator diodes are leaking more than they should. If you still see 12v the drain is elsewhere, eliminate any 'always on' things like clock, radio, alarm etc before checking things like boot light, pulling fuses, breaking down the brown circuit etc.

I've just fitted a battery cutoff switch (with a bypass to the clock) as I felt that the alarm even when not set could be the cause of my four replacement batteries in eight years.
Paul Hunt

Cheers Paul

At present I think I may have found problem, P.O had a capacitor whose wire fed from main feed from Alternator to alternator bracket, problem was the bare wires were just pushed under the spade terminal and possibly stray wires shorting to alternator body, so I just got rid of it and also fitted a proper alternator plug, touch wood I'm in the clear, till the next event appears!

again thanks for all help and suggestons
Nigel Griffiths

This thread was discussed between 09/02/2003 and 20/02/2003

MG MGB GT V8 Factory Originals Technical index

This thread is from the archive. The Live MG MGB GT V8 Factory Originals Technical BBS is active now.