MG-Cars.net

Welcome to our resource for MG Car Information.

Recommendations

Parts

TR parts and Triumph parts, TR bits, Triumph Car Spares and accessories are available for TR2, TR3, TR3A, TR4, TR4A, TR5, TR6, TR7, TR8, Spitfire and Stag and other TR models are available from British car spares and parts company LBCarCo.

Triumph Spitfire - Charging Problems

I have been out of the country for a while and left my mk1 '64 spitfire with a friend for storage. When it came to getting back on the road he put a new battery in for me but connected the earth to the negative (and ran it down to the local garage for an mot). I have now put it back to positive but the battery is not charging?

How do I go about sorting this out...could it be I have ruined the dynamo or control box?

Any help would be much appreciated.

Thanks

Nick
NickC

Nick,

Sorry to hear about your trouble.

Have you tried to charge the battery with a battery charger?

The battery may have discharged and sulphated so much it can't be recharged. If the battery will not keep a charge using an independent charger then it probably is the battery. I would check this before replacing anything. After charging check each cell specific gravity and confirm they are 1.270 to 1.290

There are resisters in behind the control box. They may have blown. If they have you need to replace the control box or try to find replacement resisters (harder to do than replace the control box). One or more relays in the control box may have failed as well.

I doubt that the dynamo is damaged. I don't think it cares too much which way the current goes.

Taht's about all I can offer without seeing or getting more information.

Good luck
Mike Petryschuk
Michael S. Petryschuk

Mike

Thanks for this.

I have actually put a new battery on but it ran from fully charged down to zero when I used the lights.

If the dynamo is hard to damage then it sounds like a new control box is needed?

Cheers

Nick
Nick C

Nick

You can check the dynamo by placing a direct line from the battery to the field winding (the small connector)and when the car is running a voltage on the big connector should be present. No voltage then the dynamo has failed. If there is voltage then the control box is probably the culprit.

Mike
Michael S. Petryschuk

I'm not quite sure if this will help, but when a new dynamo is installed, you have to "polarize" the dynamo with a procedure outlined in the service manual depending upon whether you have set the car up for positive or negative earth. It sounds like reversing the battery polarity has messed up the polarization of the dynamo fields, and you should repeat the new dynamo polarization procedures. Most of the equipment in the car doesn't care which way the battery is polarized except the radio, if you have one. If you do have a radio, some of the radios have a plug on the back for setting positive or negative earth operation. Good luck!
Al Christopher
A. R. Christopher

I have a lot of parts (NOS) for the mark 1 spitfire (MEGA cheap) if you are interested.
Al Christopher
A. R. Christopher

This thread was discussed between 21/12/2006 and 29/12/2006

Triumph Spitfire index

This thread is from the archive. The Live Triumph Spitfire BBS is active now.